const regex = /(.*?modulos\/\w*\/)(.*\/).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?modulos\\\/\\w*\\\/)(.*\\\/).*', '')
const str = `flex_src/br/com/mresolucoes/atta/modulos/vendasProduto/modulos/relatorios/valoresAutoJasper/AbaRelatorioValoresScript.as`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);