#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""^(?=.[a-z])(?=.[A-Z])(?=.\d)(?=.[$@$!%*?&])[A-Za-z\d$@$!%*?&]{8,}""
Local $sString = "aA&arunke43543"
Local $sSubst = "dfhgdfhfgjfjfhjfj"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)