import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"^(?=.[a-z])(?=.[A-Z])(?=.\\d)(?=.[$@$!%*?&])[A-Za-z\\d$@$!%*?&]{8,}\"";
final String string = "aA&arunke43543";
final String subst = "dfhgdfhfgjfjfhjfj";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}