import re
regex = re.compile(r"\"^(?=.[a-z])(?=.[A-Z])(?=.\d)(?=.[$@$!%*?&])[A-Za-z\d$@$!%*?&]{8,}\"")
test_str = "aA&arunke43543"
subst = "dfhgdfhfgjfjfhjfj"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)