const regex = /"^(?=.[a-z])(?=.[A-Z])(?=.\d)(?=.[$@$!%*?&])[A-Za-z\d$@$!%*?&]{8,}"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"^(?=.[a-z])(?=.[A-Z])(?=.\\d)(?=.[$@$!%*?&])[A-Za-z\\d$@$!%*?&]{8,}"', '')
const str = `aA&arunke43543`;
const subst = `dfhgdfhfgjfjfhjfj`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);