use strict;
my $str = 'aA&arunke43543';
my $regex = qr/"^(?=.[a-z])(?=.[A-Z])(?=.\d)(?=.[$@$!%*?&])[A-Za-z\d$@$!%*?&]{8,}"/p;
my $subst = 'dfhgdfhfgjfjfhjfj';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";