#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^v(?P<schema_version>[0-9]{2})_" & @CRLF & _
"(?P<datestamp>\d{4}-\d{2}-\d{2}_\d{2}\.\d{2}\.\d{2})_" & @CRLF & _
"(?P<metadata>[0-9a-z]{40})"
Local $sString = "# correct" & @CRLF & _
"v01_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"" & @CRLF & _
"# incorrect" & @CRLF & _
"v1_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"v01+2023-05-18T19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"v01_2023-05-18T19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"v01_2023-05-18_19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"v01+2023-05-18_19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"v1a+2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"2023-05-18+a9b8c7d6e5f4g3h2i1j0" & @CRLF & _
"2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262" & @CRLF & _
"2023,05,18+a9b8c7d6e5f4g3h2i1j0k"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")