# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^v(?P<schema_version>[0-9]{2})_
(?P<datestamp>\d{4}-\d{2}-\d{2}_\d{2}\.\d{2}\.\d{2})_
(?P<metadata>[0-9a-z]{40})
"""
test_str = ("# correct\n"
"v01_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n\n"
"# incorrect\n"
"v1_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"v01+2023-05-18T19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"v01_2023-05-18T19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"v01_2023-05-18_19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"v01+2023-05-18_19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"v1a+2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"2023-05-18+a9b8c7d6e5f4g3h2i1j0\n"
"2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
"2023,05,18+a9b8c7d6e5f4g3h2i1j0k")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.