use strict;
my $str = '# correct
v01_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
# incorrect
v1_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01+2023-05-18T19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01_2023-05-18T19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01_2023-05-18_19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01+2023-05-18_19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262
v1a+2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262
2023-05-18+a9b8c7d6e5f4g3h2i1j0
2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262
2023,05,18+a9b8c7d6e5f4g3h2i1j0k';
my $regex = qr/^v(?P<schema_version>[0-9]{2})_
(?P<datestamp>\d{4}-\d{2}-\d{2}_\d{2}\.\d{2}\.\d{2})_
(?P<metadata>[0-9a-z]{40})/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}