import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^v(?P<schema_version>[0-9]{2})_\n"
+ "(?P<datestamp>\\d{4}-\\d{2}-\\d{2}_\\d{2}\\.\\d{2}\\.\\d{2})_\n"
+ "(?P<metadata>[0-9a-z]{40})";
final String string = "# correct\n"
+ "v01_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n\n"
+ "# incorrect\n"
+ "v1_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "v01+2023-05-18T19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "v01_2023-05-18T19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "v01_2023-05-18_19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "v01+2023-05-18_19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "v1a+2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "2023-05-18+a9b8c7d6e5f4g3h2i1j0\n"
+ "2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262\n"
+ "2023,05,18+a9b8c7d6e5f4g3h2i1j0k";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}