import Foundation
let pattern = #"""
^v(?P<schema_version>[0-9]{2})_
(?P<datestamp>\d{4}-\d{2}-\d{2}_\d{2}\.\d{2}\.\d{2})_
(?P<metadata>[0-9a-z]{40})
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
# correct
v01_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
# incorrect
v1_2023-05-18_19.24.36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01+2023-05-18T19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01_2023-05-18T19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01_2023-05-18_19:24:36_92bea41ab3b52b8f1015cd7a8b64713326f1a262
v01+2023-05-18_19.24.36+92bea41ab3b52b8f1015cd7a8b64713326f1a262
v1a+2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262
2023-05-18+a9b8c7d6e5f4g3h2i1j0
2023-50-99+92bea41ab3b52b8f1015cd7a8b64713326f1a262
2023,05,18+a9b8c7d6e5f4g3h2i1j0k
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)