# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*IP: (?!63\.3\.245\.123)(\d+.\d+.\d+.\d+).*$/$1/sg;t' <<< "The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Edit Ticket Post
E-mail: customeremail@ip.com IP: 98.154.227.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Regards,
Edit Ticket Post
E-mail: myemail@google.com IP: 63.3.245.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff"