const regex = /^.*IP: (?!63\.3\.245\.123)(\d+.\d+.\d+.\d+).*$/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*IP: (?!63\\.3\\.245\\.123)(\\d+.\\d+.\\d+.\\d+).*$', 'sg')
const str = `The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Edit Ticket Post
E-mail: customeremail@ip.com IP: 98.154.227.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Regards,
Edit Ticket Post
E-mail: myemail@google.com IP: 63.3.245.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);