re = /^.*IP: (?!63\.3\.245\.123)(\d+.\d+.\d+.\d+).*$/
str = 'The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Edit Ticket Post
E-mail: customeremail@ip.com IP: 98.154.227.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Regards,
Edit Ticket Post
E-mail: myemail@google.com IP: 63.3.245.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result