import Foundation
let pattern = #"^.*IP: (?!63\.3\.245\.123)(\d+.\d+.\d+.\d+).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Edit Ticket Post
E-mail: customeremail@ip.com IP: 98.154.227.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Regards,
Edit Ticket Post
E-mail: myemail@google.com IP: 63.3.245.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)