use strict;
my $str = 'The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Edit Ticket Post
E-mail: customeremail@ip.com IP: 98.154.227.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Regards,
Edit Ticket Post
E-mail: myemail@google.com IP: 63.3.245.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff';
my $regex = qr/^.*IP: (?!63\.3\.245\.123)(\d+.\d+.\d+.\d+).*$/sp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";