using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*IP: (?!63\.3\.245\.123)(\d+.\d+.\d+.\d+).*$";
string substitution = @"$1";
string input = @"The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Edit Ticket Post
E-mail: customeremail@ip.com IP: 98.154.227.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff
Regards,
Edit Ticket Post
E-mail: myemail@google.com IP: 63.3.245.123
The
Rest
of this code
is just HTML and stuffThe
Rest
of this code
is just HTML and stuff";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}