#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([a-zA-Z]+\.{0,1})+)\.[0-9]+"
Local $sString = "summer1969 2014-03-07 Test.list.everything.1234 123.4.4.34 moreCode"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")