$re = '/(([a-zA-Z]+\.{0,1})+)\.[0-9]+/';
$str = 'summer1969 2014-03-07 Test.list.everything.1234 123.4.4.34 moreCode';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);