// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([a-zA-Z]+\.{0,1})+)\.[0-9]+").unwrap();
let string = "summer1969 2014-03-07 Test.list.everything.1234 123.4.4.34 moreCode";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}