import Foundation
let pattern = #"(([a-zA-Z]+\.{0,1})+)\.[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"summer1969 2014-03-07 Test.list.everything.1234 123.4.4.34 moreCode"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}