const regex = /(([a-zA-Z]+\.{0,1})+)\.[0-9]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-zA-Z]+\\.{0,1})+)\\.[0-9]+', '')
const str = `summer1969 2014-03-07 Test.list.everything.1234 123.4.4.34 moreCode`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}