re = /(([a-zA-Z]+\.{0,1})+)\.[0-9]+/
str = 'summer1969 2014-03-07 Test.list.everything.1234 123.4.4.34 moreCode'
# Print the match result
str.match(re) do |match|
puts match.to_s
end