#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![\d.])(?:\d*\.\d+|\d+\.\d*)(?![\d.])"
Local $sString = "1.0A" & @CRLF & _
"1.B" & @CRLF & _
".1" & @CRLF & _
"." & @CRLF & _
"1.0.0" & @CRLF & _
"1.0.1" & @CRLF & _
"20.20.20.30" & @CRLF & _
"12345.657.345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")