const regex = new RegExp('(?<![\\d.])(?:\\d*\\.\\d+|\\d+\\.\\d*)(?![\\d.])', 'gm')
const str = `1.0A
1.B
.1
.
1.0.0
1.0.1
20.20.20.30
12345.657.345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}