using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\d.])(?:\d*\.\d+|\d+\.\d*)(?![\d.])";
string input = @"1.0A
1.B
.1
.
1.0.0
1.0.1
20.20.20.30
12345.657.345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}