re = /(?<![\d.])(?:\d*\.\d+|\d+\.\d*)(?![\d.])/m
str = '1.0A
1.B
.1
.
1.0.0
1.0.1
20.20.20.30
12345.657.345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end