import re
regex = re.compile(r"(?<![\d.])(?:\d*\.\d+|\d+\.\d*)(?![\d.])", flags=re.MULTILINE)
test_str = ("1.0A\n"
"1.B\n"
".1\n"
".\n"
"1.0.0\n"
"1.0.1\n"
"20.20.20.30\n"
"12345.657.345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")