#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?://)?(?:api\.|www\.)?((?:[^\s.]+\.)+[a-z]{2,})"
Local $sString = "ClientRedirectUrl: https://sonyco.it/wc-api/WC_paylink/?wc_order=673927" & @CRLF & _
"ClientUri: https://www.sonyco.it" & @CRLF & _
"Site: https://yzx80.paylink.net/" & @CRLF & _
"" & @CRLF & _
"www.paylink.fr:443" & @CRLF & _
"api.ornage.com" & @CRLF & _
"" & @CRLF & _
"http://www.paylink.fr:443" & @CRLF & _
"http://api.ornage.com" & @CRLF & _
"" & @CRLF & _
"https://sonyco.it/wc-api/WC_paylink/?wc_order=673927" & @CRLF & _
"https://www.sonyco.it" & @CRLF & _
"https://yzx80.sonyco.it/ " & @CRLF & _
"http://app.sonyco.it" & @CRLF & _
"www.sonyco.it:443" & @CRLF & _
"api.sonyco.it" & @CRLF & _
"http://www.sonyco.it:443"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")