import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?://)?(?:api\\.|www\\.)?((?:[^\\s.]+\\.)+[a-z]{2,})";
final String string = "ClientRedirectUrl: https://sonyco.it/wc-api/WC_paylink/?wc_order=673927\n"
+ "ClientUri: https://www.sonyco.it\n"
+ "Site: https://yzx80.paylink.net/\n\n"
+ "www.paylink.fr:443\n"
+ "api.ornage.com\n\n"
+ "http://www.paylink.fr:443\n"
+ "http://api.ornage.com\n\n"
+ "https://sonyco.it/wc-api/WC_paylink/?wc_order=673927\n"
+ "https://www.sonyco.it\n"
+ "https://yzx80.sonyco.it/ \n"
+ "http://app.sonyco.it\n"
+ "www.sonyco.it:443\n"
+ "api.sonyco.it\n"
+ "http://www.sonyco.it:443";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}