# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https?://)?(?:api\.|www\.)?((?:[^\s.]+\.)+[a-z]{2,})"
test_str = ("ClientRedirectUrl: https://sonyco.it/wc-api/WC_paylink/?wc_order=673927\n"
"ClientUri: https://www.sonyco.it\n"
"Site: https://yzx80.paylink.net/\n\n"
"www.paylink.fr:443\n"
"api.ornage.com\n\n"
"http://www.paylink.fr:443\n"
"http://api.ornage.com\n\n"
"https://sonyco.it/wc-api/WC_paylink/?wc_order=673927\n"
"https://www.sonyco.it\n"
"https://yzx80.sonyco.it/ \n"
"http://app.sonyco.it\n"
"www.sonyco.it:443\n"
"api.sonyco.it\n"
"http://www.sonyco.it:443")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.