re = /(?:https?:\/\/)?(?:api\.|www\.)?((?:[^\s.]+\.)+[a-z]{2,})/m
str = 'ClientRedirectUrl: https://sonyco.it/wc-api/WC_paylink/?wc_order=673927
ClientUri: https://www.sonyco.it
Site: https://yzx80.paylink.net/
www.paylink.fr:443
api.ornage.com
http://www.paylink.fr:443
http://api.ornage.com
https://sonyco.it/wc-api/WC_paylink/?wc_order=673927
https://www.sonyco.it
https://yzx80.sonyco.it/
http://app.sonyco.it
www.sonyco.it:443
api.sonyco.it
http://www.sonyco.it:443'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end