use strict;
my $str = 'ClientRedirectUrl: https://sonyco.it/wc-api/WC_paylink/?wc_order=673927
ClientUri: https://www.sonyco.it
Site: https://yzx80.paylink.net/
www.paylink.fr:443
api.ornage.com
http://www.paylink.fr:443
http://api.ornage.com
https://sonyco.it/wc-api/WC_paylink/?wc_order=673927
https://www.sonyco.it
https://yzx80.sonyco.it/
http://app.sonyco.it
www.sonyco.it:443
api.sonyco.it
http://www.sonyco.it:443';
my $regex = qr/(?:https?://)?(?:api\.|www\.)?((?:[^\s.]+\.)+[a-z]{2,})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}