const regex = new RegExp('(?:https?://)?(?:api\\.|www\\.)?((?:[^\\s.]+\\.)+[a-z]{2,})', 'gm')
const str = `ClientRedirectUrl: https://sonyco.it/wc-api/WC_paylink/?wc_order=673927
ClientUri: https://www.sonyco.it
Site: https://yzx80.paylink.net/
www.paylink.fr:443
api.ornage.com
http://www.paylink.fr:443
http://api.ornage.com
https://sonyco.it/wc-api/WC_paylink/?wc_order=673927
https://www.sonyco.it
https://yzx80.sonyco.it/
http://app.sonyco.it
www.sonyco.it:443
api.sonyco.it
http://www.sonyco.it:443`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}