use strict;
my $str = 'P1, PROTECTED 1
P3, PROTECTED 3
P10, PROTECTED 10';
my $regex = qr/^\D*(\d+).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";