re = /^\D*(\d+).*/m
str = 'P1, PROTECTED 1
P3, PROTECTED 3
P10, PROTECTED 10'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result