import re
regex = re.compile(r"^\D*(\d+).*", flags=re.MULTILINE)
test_str = ("P1, PROTECTED 1\n"
"P3, PROTECTED 3\n"
"P10, PROTECTED 10")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)