// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\D*(\d+).*").unwrap();
let string = "P1, PROTECTED 1
P3, PROTECTED 3
P10, PROTECTED 10";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}