#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![^\\ ])\d{8,10}"
Local $sString = "\listName 082713\type_102113\25765199.bpo.pdf" & @CRLF & _
"\list\listName 082713\type_102113\25765280.bpo.pdf" & @CRLF & _
"\list\listName 082713\type_102113\25779752.bpo.pdf" & @CRLF & _
"\list\listName 082713\type_102113\NAME1 0020412714_BPO.pdf" & @CRLF & _
"\list\listName 082713\type_102113\NAME2 0020421822_BPO.pdf" & @CRLF & _
"\list\listName 082713\type_102113\NAME3 0020443370_BPO.pdf" & @CRLF & _
"" & @CRLF & _
"a:\listName 082713\type_102113\25765199.bpo.pdf" & @CRLF & _
"a:\listName 082713\type_102113\25765280.bpo.pdf" & @CRLF & _
"a:\listName 082713\type_102113\25779752.bpo.pdf" & @CRLF & _
"a:\listName 082713\type_102113\NAME1 0020412714_BPO.pdf" & @CRLF & _
"a:\listName 082713\type_102113\NAME2 0020421822_BPO.pdf" & @CRLF & _
"a:\listName 082713\type_102113\NAME3 0020443370_BPO.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")