use strict;
my $str = '\\listName 082713\\type_102113\\25765199.bpo.pdf
\\list\\listName 082713\\type_102113\\25765280.bpo.pdf
\\list\\listName 082713\\type_102113\\25779752.bpo.pdf
\\list\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf
\\list\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf
\\list\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf
a:\\listName 082713\\type_102113\\25765199.bpo.pdf
a:\\listName 082713\\type_102113\\25765280.bpo.pdf
a:\\listName 082713\\type_102113\\25779752.bpo.pdf
a:\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf
a:\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf
a:\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf';
my $regex = qr~(?<![^\\ ])\d{8,10}~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}