import Foundation
let pattern = #"(?<![^\\ ])\d{8,10}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\listName 082713\type_102113\25765199.bpo.pdf
\list\listName 082713\type_102113\25765280.bpo.pdf
\list\listName 082713\type_102113\25779752.bpo.pdf
\list\listName 082713\type_102113\NAME1 0020412714_BPO.pdf
\list\listName 082713\type_102113\NAME2 0020421822_BPO.pdf
\list\listName 082713\type_102113\NAME3 0020443370_BPO.pdf
a:\listName 082713\type_102113\25765199.bpo.pdf
a:\listName 082713\type_102113\25765280.bpo.pdf
a:\listName 082713\type_102113\25779752.bpo.pdf
a:\listName 082713\type_102113\NAME1 0020412714_BPO.pdf
a:\listName 082713\type_102113\NAME2 0020421822_BPO.pdf
a:\listName 082713\type_102113\NAME3 0020443370_BPO.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)