$re = '~(?<![^\\\\ ])\d{8,10}~';
$str = '\\listName 082713\\type_102113\\25765199.bpo.pdf
\\list\\listName 082713\\type_102113\\25765280.bpo.pdf
\\list\\listName 082713\\type_102113\\25779752.bpo.pdf
\\list\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf
\\list\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf
\\list\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf
a:\\listName 082713\\type_102113\\25765199.bpo.pdf
a:\\listName 082713\\type_102113\\25765280.bpo.pdf
a:\\listName 082713\\type_102113\\25779752.bpo.pdf
a:\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf
a:\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf
a:\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);