import re
regex = re.compile(r"(?<![^\\ ])\d{8,10}")
test_str = ("\\listName 082713\\type_102113\\25765199.bpo.pdf\n"
"\\list\\listName 082713\\type_102113\\25765280.bpo.pdf\n"
"\\list\\listName 082713\\type_102113\\25779752.bpo.pdf\n"
"\\list\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf\n"
"\\list\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf\n"
"\\list\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf\n\n"
"a:\\listName 082713\\type_102113\\25765199.bpo.pdf\n"
"a:\\listName 082713\\type_102113\\25765280.bpo.pdf\n"
"a:\\listName 082713\\type_102113\\25779752.bpo.pdf\n"
"a:\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf\n"
"a:\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf\n"
"a:\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")