using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\\ ])\d{8,10}";
string input = @"\listName 082713\type_102113\25765199.bpo.pdf
\list\listName 082713\type_102113\25765280.bpo.pdf
\list\listName 082713\type_102113\25779752.bpo.pdf
\list\listName 082713\type_102113\NAME1 0020412714_BPO.pdf
\list\listName 082713\type_102113\NAME2 0020421822_BPO.pdf
\list\listName 082713\type_102113\NAME3 0020443370_BPO.pdf
a:\listName 082713\type_102113\25765199.bpo.pdf
a:\listName 082713\type_102113\25765280.bpo.pdf
a:\listName 082713\type_102113\25779752.bpo.pdf
a:\listName 082713\type_102113\NAME1 0020412714_BPO.pdf
a:\listName 082713\type_102113\NAME2 0020421822_BPO.pdf
a:\listName 082713\type_102113\NAME3 0020443370_BPO.pdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}