using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:alnum:]]";
string input = @"i want to block or remove all unwanted characters from from my site
characters like ᾄҭ ᾄ or нєℓℓσ ĤĔĹĹŐ etc..
1234";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}