import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[[:alnum:]]";
final String string = "i want to block or remove all unwanted characters from from my site\n\n"
+ "characters like ᾄҭᾄ or нєℓℓσ ĤĔĹĹŐ etc..\n\n"
+ "1234";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}