use strict;
my $str = 'i want to block or remove all unwanted characters from from my site
characters like ᾄҭᾄ or нєℓℓσ ĤĔĹĹŐ etc..
1234';
my $regex = qr/[[:alnum:]]/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}