$re = '/[[:alnum:]]/u';
$str = 'i want to block or remove all unwanted characters from from my site
characters like ᾄҭᾄ or нєℓℓσ ĤĔĹĹŐ etc..
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);