// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[[:alnum:]]").unwrap();
let string = "i want to block or remove all unwanted characters from from my site
characters like ᾄҭᾄ or нєℓℓσ ĤĔĹĹŐ etc..
1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}