#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https:\/\/demo.happy-visitor.com\/"
Local $sString = "http://www.website.com" & @CRLF & _
"https://www.website.com" & @CRLF & _
"www.website.com" & @CRLF & _
"website.com" & @CRLF & _
"http://website.com" & @CRLF & _
"https://website.com" & @CRLF & _
"fb.com" & @CRLF & _
"https://demo.happy-visitor.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")